Python и GTK3 приложения сбой при импорте "указать" (в Python-указать)

Я пытаюсь интегрировать мой Python и GTK3 приложения с меню сообщений в Ubuntu и каждый раз, когда я пытаюсь импортировать "указать" (в Python-указать) мои приложение падает, следующие изменения:

в /usr/lib в/Вместо python2.7/дист-пакеты/файлы/константы.пы:24: предупреждение: g_boxed_type_register_static: утверждение `g_type_from_name (имя) == 0' не удалось
 файлы импорта._gobject
в /usr/lib в/Вместо python2.7/дист-пакетов/приложений GTK-2.0/БТК/__инит__.пы:40: предупреждение: указанный размер класса для типа `PyGtkGenericCellRenderer' меньше, чем родителей типа `GtkCellRenderer класса размер
 от импорта _gtk ГТК 
в /usr/lib в/Вместо python2.7/дист-пакетов/приложений GTK-2.0/БТК/__инит__.пы:40: предупреждение: g_type_get_qdata: утверждение `узел != Значение null не удалось
 от импорта _gtk ГТК 

Это похоже на какую-то столкновение между GTK2 и GTK3... в любом случае, как бы я идти о фиксации этого?

Спасибо.

+725
Guillaume Vincent 15 мар. 2017 г., 6:58:05
17 ответов

Как правило, существует множество видов оплаты, мы могли бы поддержать (т. е. платежи с мобильных телефонов или географической специфики), но каждая нуждается в много работы, чтобы интегрировать. С трудности распознавания мошенничества, налоговых и технической интеграции нашей главной целью является, чтобы иметь наиболее популярных и широко используемых методов.

PayPal очень популярен и мы спросили об этом довольно много пользователей, так что это очевидно одно. Это просто вопрос приоритетов и ресурсов!

+989
Kalendae 03 февр. '09 в 4:24

По моему опыту это сочетание:

  1. Центр программного обеспечения -- "Вы имеете в виду все это бесплатно?"
  2. Тот факт, что он не заражен вредоносными программами. Многие пользователи переносятся, когда они приходят ко мне за помощью поймав вирусов и вредоносных программ, что требует целого переустановить
  3. Сообщество. Люди на самом деле чувствую, что это легче получить помощь с Ubuntu, чем в Windows.

Во многих случаях их старые приложения нормально работают через Wine, поэтому они часто имеют очень мало на что жаловаться.

+955
Mehdi Rejraji 2 дек. 2014 г., 23:06:26

Моя Ubuntu 13.04 больше не загрузиться. Вечный черный экран. Если я нажмите сочетание клавиш Alt+Ctrl+клавиша Ф1 я вижу, что она застряла на "проверка состояния батареи [ОК]". Я бы хотел пойти с

судо apt-получить установку ГРМ

но я не могу зайти на терминал tty2, tty3 и т. д. Они правильно попросить мой ник, а потом они заставят меня ждать много, спросите пароль и мне еще подождать. Спустя много времени (... много) лучшее, что я смогла добиться визуализации "Documentantion https://help.ubuntu.com". Я никогда не может достигнуть той точки, где я могу отдавать команды. Плюс, во время длительных пауз, каждые 2 минуты он дает messagge такой:

Информация: задача ХХХ заблокирован в течение более чем 120 секунд.

Любое предложение? Извините за мой плохой английский и спасибо всем за внимание.

+910
kalhartt 8 апр. 2011 г., 8:04:56

Вы должны быть в состоянии видеть ваш сеть посредством уведомления через libnotify сообщения.Единственное, что я думаю, что вы пропустите ваш статус в сети, который вы можете проверить через командную строку, если требуется. Вы можете гарантировать, что Alt-F2 работает для 'запуска', или что у вас есть какой-либо другой метод повторного запуска в GNOME-сделать, если он выходит из строя (что он делает иногда). В худшем случае, всегда есть контрол-альт-Ф1 переходить на консоли.

+863
Oxii Sp 28 сент. 2016 г., 4:31:02

идти (http://www.upubuntu.com/2013/02/installupgrade-to-linux-kernel-379-in.html) и поместить код в терминал

это последнее ядро 3.7.9 .....сохраните его в закладки, потому что будет проверять, если есть более

+795
Nu2Overflow 19 сент. 2016 г., 3:40:04

Когда я запускаю версию Ubuntu в Firefox, нет кнопки восстановить предыдущую сессию, только некоторые кнопки в Ubuntu. Как я могу восстановить сессию в версию Ubuntu это?

+657
user989731 4 февр. 2014 г., 17:03:24

Недавно я установил Pidgin и попытался установить пиджин-facebookchat. Центр приложений Ubuntu теперь говорит, что пиджин поврежден, поэтому я нажимаю на ремонт, но ничего не изменится. Я пробовал команду sudo apt-получить продувки пиджин , но я получаю эту ошибку:

Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Возможно, вы захотите воспользоваться 'apt-получить -Ф Install' для исправления этих:
Следующие пакеты имеют неудовлетворенные зависимости:
 пиджин-данные : перерывы: пиджин-facebookchat (< 1.69-2), но 1.69 должен быть установлен
 пиджин-через libnotify : зависит: пиджин (< 1:3.0), но он не будет установлен
 Зависит: пиджин (>= 1:2.10), но он не будет установлен
Е: неудовлетворенные зависимости. Попытайтесь выполнить 'apt-получить -установить Ф' без упаковки (или указать решения).

И судо АПТ-Гет-Ф установить результаты в этом ошибка

Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Исправление зависимостей... сделано
Следующие пакеты были установлены автоматически и больше не требуется:
 язык-блок-кде-ж-Ганс-выбор на Firefox-локаль-ж-Ганс языковых пакетов из KDE-среда KDE-команде l10n-системы
 язык-упак-ж-Ханс-библиотеки KDE-команде l10n-zhcn языке-упаковка-ж-Ганс языковых пакетов-кде-ж-Ганс
язык-блок-кде-собственная база
Воспользоваться 'apt-получить autoremove', чтобы удалить их.
Следующие дополнительные пакеты будут установлены:
пиджин-facebookchat
Следующие пакеты будут обновлены:
пиджин-facebookchat
1 обновлено, 0 установлено новых, 0 для удаления и 31 не обновляется.
1 не полностью установлены или удалены.
Нужно получить 0 б/39.8 КБ архивов.
После этой операции, 139 КБ дополнительное дисковое пространство будет использоваться.
Вы действительно хотите продолжить [д/н]? г
с dpkg: предупреждение: не установлен соответствующий пакет пиджин-facebookchat:для amd64

Как я могу удалить Pidgin из Мой компьютер?, Он также блокировки других приложений.

+538
J Luis Loya 28 сент. 2013 г., 1:03:49

Вы должны изменить кальмаров.файл Conf в /etc/инит, так что он только начинается, когда сеть:

начало (запущен сети)

Вы можете найти намного больше информации здесь, и смотреть на файлы в /etc/инит/ реж.

Этот вопрос также должен помочь. Если вы предпочитаете, чтобы настроить его с GUI, посмотрите здесь.

+497
carolle 31 июл. 2018 г., 3:07:34

Его не ясно, если запущена 32-разрядная или 64-разрядная. Однако у меня такая же проблема, которая возникает каждый раз, когда приходит обновление, так что обновления флэш-плагин пакет. Для 64-разрядных изначально проверьте свой файл /usr/lib в/скачайте/для i386/linux и npviewer настройки как в этом посте

http://heratech.net/blog/sham/cant-click-playpause-flash-youtube-etc-ubuntu

Затем через менеджер пакетов Synaptic (система - > меню Администрирование) ищите "Flash" и переустановить "flashplugin-установщик". Это работает для меня каждый раз, мы надеемся, это поможет вам.

+445
mdiehl13 31 июл. 2010 г., 9:49:56

Попробуйте:

судо ютуб-дл -у

чтобы обновить его, и снова попробовать некоторые видео.

+413
Dursun Saadet 31 дек. 2012 г., 21:35:38

Вы также можете принудительно проверить на варианты развития (так как вышел квантовыми это не будет иметь никакого существенного различия для вас), открыв терминал и введя:

обновление-менеджер -D и
+346
user1950278 13 авг. 2013 г., 5:51:52

Отлично работает здесь

Проверено на:

  • В Ubuntu 13.04
  • HTC один X с Android 4.1.1
+329
Ope B 1 окт. 2014 г., 12:26:09

У меня есть свой сервер приложение на C, я связываю мой сервер по адресу localhost 127.0.0.1 и пусть его слушают в первом случае на порт 10000 и во втором случае на порт 20000. Когда я запускаю команду, я как lsof | grep в ИС в последний столбец: в первом случае: на localhost:в Webmin (слушать)
и, во втором случае: на localhost:20000 (слушать)

Поэтому вместо того, чтобы порт 10000 есть в Webmin. Что это значит? Я нашел этот. Он говорит, что Webmin-это веб-интерфейс для администрирования системы Unix, но это не достаточно понятное объяснение. Так что в Webmin именно имеете в виду?

+271
Tummie Bayhi 1 нояб. 2012 г., 1:19:33

Это известная ошибка в Наутилус. В настоящее время нет никакого известного исправить других, чем отключить Наутилус рисунок рабочего стола:

Временное решение я нашел, чтобы отключить имеют файлменеджер ручкой на столе'. Вы можете использовать гном-твик-инструмент для этого. Минус в том, что значки на рабочем столе больше не показывают.

+212
Pradeep C 27 дек. 2015 г., 15:29:41

Да, резервного копирования #2 будет иметь файл и все будет работать, как вы ожидаете.

Однако! Обратите внимание, что дежа ДУП уникально идентифицирует USB-накопителя, идентификатор файловой системы, так что вы можете не "фишка" это в некотором роде просто обмен дисками. Вы на самом деле нужно изменить свое местоположение для резервного копирования в настройках системы можно поменять диск дежа ДУП использует.

+155
Jason Spinola 31 мар. 2013 г., 17:36:33

Я использую Ubuntu 12.04 со старым процессором Интел Пентиум (мобильный процессор Intel GL40) и Интел ГМА 4500м встроенная видеокарта.

Я скачал Linux-версию из Steam и TF2 через Steam без использования какой-либо эмулятор или других программ. Поскольку я получил сообщение об ошибке запуска ТФ2. Я обновил драйвер видеокарты.

Теперь я могу запустить ТФ2, но я получаю странный графический баг и не могу играть (например, клапан интро это обратно в сочетании со странным зеленый/черный/синий пиксельный узор - это не играбельно хотя у меня ощущение, что я нахожусь в главном меню и услышать звук)

Есть ли способ играть в ТФ2 без эмулятора или по крайней мере того, чтобы загрузить снова (версии Windows, например)?

+117
Dethpickle 22 нояб. 2014 г., 22:48:25

Я просто создана UbuntuOne, и готов для синхронизации. Папка "Мои Документы" имеет возможность синхронизации, но не отдельные подпапки. Я не хочу, чтобы синхронизировать все папки "Мои Документы" - есть ли способ, чтобы выбрать только определенные папки для синхронизации?

+54
hoppa 1 дек. 2014 г., 10:49:06

Показать вопросы с тегом